Canvas - Software Requirements

To see the list of the software that users need in order to access Canvas, see Instructure's documentation on supported browsers:

Which browsers does Canvas support?

Instructure updates the list of supported browsers and versions regularly. Please note that Canvas only supports the "the current and first previous major releases" of any given browser, so users will need to keep their software up to date.

Not all features may work correctly in unsupported browsers, and users of unsupported browsers or browser versions may see the following error message: "Your browser does not meet the minimum requirements for Canvas."



Keywords:Firefox, Chrome, IE, Internet Explorer, Edge, Safari, Opera   Doc ID:91256
Owner:Thomas A.Group:UW System Administration DLE
Created:2019-04-23 13:17 CDTUpdated:2019-04-25 08:31 CDT
Sites:UW Green Bay, UW Parkside, UW Platteville, UW Stout, UW System Administration DLE, UW-Extension and Colleges, UW-Milwaukee Center for Excellence in Teaching and Learning
Feedback:  0   0