News and Announcements

  • Canvas - Unsupported Browser Message   Apr 23, 2019, 2:00 PM CDT

    On 04/20/2019, users who don't meet Canvas's software requirements may have begun to see the following error message: "Your browser does not meet the minimum requirements for Canvas."

  • Canvas - Authentication Certificate Rollover 04/17/19   Apr 17, 2019, 1:46 PM CDT

    After Instructure completed the certificate rollover today, some campuses reported authentication errors.

  • Subscribe to DLE KB News and Announcements   Apr 11, 2019, 4:24 PM CDT

    If you're reading this, you may want to sign up for automatic notifications when new items are posted to the Digital Learning Environment (DLE) KnowledgeBase (KB) News and Announcements.

News RSS More news